TelcoSwitch Reseller Portal
Incident Report for TelcoSwitch Limited
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 19, 2019 - 14:34 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Feb 19, 2019 - 14:33 GMT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Feb 19, 2019 - 10:43 GMT
Investigating
We are investigating an issue where the order process times out before order completion.

Currently orders cannot be processed. If the order is urgent please call 0330 122 7000 and place the order via telephone or send an email into opsteam@telcoswitch.com

Thanks for your understanding

TelcoSwitch Ops Team
Posted about 1 month ago. Feb 19, 2019 - 10:43 GMT
This incident affected: TelcoSwitch Portal (Reseller Portal).