Power Cut - London HQ
Incident Report for TelcoSwitch Group
Resolved
This incident has been resolved.
Posted Nov 24, 2022 - 17:20 GMT
Identified
We are experiencing a power cut at HQ please email support with any technical queries.
Posted Nov 24, 2022 - 14:11 GMT