Outbound voice service degradation
Incident Report for TelcoSwitch Group
Resolved
This incident has been resolved, the service will continue to be monitored diligently.
Posted Aug 25, 2021 - 12:43 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2021 - 12:19 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2021 - 12:18 BST
Investigating
We are currently investigating an issue relating to outbound call degradation
Posted Aug 25, 2021 - 12:16 BST
This incident affected: CallSwitch (Hosted Telephony Platform).