Outbound calls not connecting
Incident Report for TelcoSwitch Group
Resolved
This brief period of intermittent outbound calling has now been resolved.

The root cause of the problem was down to a faulty load balancer, this system has now been restored to full health and our engineers continue to monitor the traffic closely to ensure service is running smoothly once again.
Posted Feb 01, 2021 - 13:59 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2021 - 13:40 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2021 - 13:39 GMT
Investigating
We are currently investigating this issue.
Posted Feb 01, 2021 - 13:33 GMT
This incident affected: CallSwitch (Hosted Telephony Platform).