ADSL & FTTC Issues
Incident Report for TelcoSwitch Limited
Resolved
This issue has now been resolved and all broadband circuits are returning to service.

Some routers may need a restart to prompt them into reconnecting.
Posted 7 months ago. Feb 11, 2019 - 10:36 GMT
Investigating
We are currently seeing outages on ADSL and FTTC connections, initial reports suggest this is on the BT side and we are investigating with their engineers.

Ethernet and Leased Line circuits remain in service and unaffected.
Posted 7 months ago. Feb 11, 2019 - 09:30 GMT
This incident affected: NetSwitch (Broadband Services).