Support Ticketing System
Incident Report for TelcoSwitch Group
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 14:29 BST
Monitoring
The service has been restored and Zendesk is accessible once again
Posted Sep 09, 2020 - 13:27 BST
Investigating
Our support ticketing system Zendesk is currently experiencing an outage, this is stopping our agents from being able to access active and new tickets.

If you require urgent support, please call through to our technicians on 03301227000 - option 2.
Posted Sep 09, 2020 - 13:21 BST
This incident affected: Support Portal.