CallSwitch Communicator Apps Licensing Issues
Incident Report for TelcoSwitch Limited
Resolved
This incident has now been resolved and steps have been taken to ensure that it does not reoccur.
Posted about 1 year ago. Sep 05, 2018 - 15:35 BST
Monitoring
The licensing issues have now been resolved and engineers are monitoring the service.
Posted about 1 year ago. Sep 05, 2018 - 10:06 BST
Investigating
We are aware of an issue with the licensing service for CallSwitch Communicator apps that is preventing some users from logging in this morning. Engineers are investigating and we expect a quick resolution.
Posted about 1 year ago. Sep 05, 2018 - 09:25 BST
This incident affected: CallSwitch (Hosted Telephony Platform).