ADSL & FTTC Outage
Incident Report for TelcoSwitch Limited
Resolved
Connectivity to affected ADSL and FTTC circuits has now been restored.

Due to an unavoidable reliance on third parties for "last mile" connectivity it is advisable to use ADSL and FTTC only for ephemeral and backup circuits - customers using ADSL and FTTC for primary connections are advised to discuss ethernet connectivity options with your account manager.
Posted 5 months ago. May 30, 2019 - 15:05 BST
Investigating
Engineers are currently investigating an outage affecting some ADSL and FTTC broadband circuits.

Ethernet circuits are not affected by this issue.
Posted 5 months ago. May 30, 2019 - 14:09 BST
This incident affected: NetSwitch (Broadband Services).