Issues with inbound telephone calls
Incident Report for TelcoSwitch Group
Resolved
This incident has been resolved. The TelcoSwitch team is continuing to monitor for any unusual activity or call handling behaviour.
Posted Jan 26, 2023 - 10:40 GMT
Update
Please see our full incident report for loss of inbound services to some customers earlier today, caused by the wider global outage on Microsoft Azure.

https://download.callswitch.net/assets/INCIDENT_REPORT-20230125.pdf

Please contact support@telcoswitch.com should you require further information.
Posted Jan 25, 2023 - 17:23 GMT
Monitoring
We believe the issue with inbound calls has been resolved.

We will continue to monitor this incident over the next 24 hours.

If you are still experiencing issues with inbound calls, please contact the TelcoSwitch support team; support@telcoswitch.com
Posted Jan 25, 2023 - 12:08 GMT
Investigating
Our team has reported that telephone calls inbound are showing to have issues. This is not impacting TelcoSwitch globally, however, we are investigating the issue further.
Posted Jan 25, 2023 - 11:47 GMT
This incident affected: CallSwitch (Hosted Telephony Platform) and SipSwitch (SIP Platform).