CallSwitch Voice Servers - Volta
Incident Report for TelcoSwitch Group
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 20:19 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 04, 2022 - 20:09 GMT
Investigating
We are currently investigating this issue.
Posted Nov 04, 2022 - 19:48 GMT
This incident affected: CallSwitch (Hosted Telephony Platform).