Outbound Calling
Incident Report for TelcoSwitch Group
Postmortem

At 10:24AM, we started receiving reports of outbound call issues. This was immediately escalated to the operations team and CTO. Investigations began immediately, and the issue -  caused by a faulty database instance in a high availability database cluster responsible for SIP account authentication - was resolved at 10:41AM.

This database contains sip account credentials, and is used for server and customer authentication for placing outbound calls. It runs as a highly available database cluster within Amazon Web Services (AWS). Although monitoring as well as health checks within AWS did not show any issues with this cluster, one of the server instances was returning invalid username/password on connection requests. The issue was resolved by rebooting this instance within the cluster.

Posted Jun 27, 2022 - 11:34 BST

Resolved
The incident has been resolved. We will post a short technical statement on this status page within the next hour.
Posted Jun 27, 2022 - 10:56 BST
Monitoring
A fix has been applied and we are monitoring the outbound calling services across the platform.
Posted Jun 27, 2022 - 10:48 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 27, 2022 - 10:44 BST
Update
We are continuing to investigate this issue. Our technical team have seen where the issue is occurring. As soon as we have this confirmed we will update the our status accordingly.
Posted Jun 27, 2022 - 10:42 BST
Investigating
We are currently investigating this issue.
Posted Jun 27, 2022 - 10:29 BST
This incident affected: CallSwitch (Hosted Telephony Platform) and SipSwitch (SIP Platform).