Reports of Call Quality Degredation
Incident Report for TelcoSwitch Group
Resolved
After monitoring traffic closely over the weekend our NOC are satisfied service is fully operational and are closing this incident as resolved.
Posted Jul 15, 2024 - 09:10 BST
Update
We're seeing service returning to normal across our network and will continue to monitor today and over the weekend. Issue will be re-assessed and marked as resolved on Monday if no further reports.
Posted Jul 12, 2024 - 13:19 BST
Update
We're still monitoring for improvements across the affected areas of traffic. Next update will be provided as soon as possible.
Posted Jul 12, 2024 - 12:37 BST
Monitoring
A resolution is being implemented and our NOC are monitoring the affected traffic for improvements. Expected resolution and next update inside 30 minutes.
Posted Jul 12, 2024 - 12:10 BST
Identified
We've identified an issue with the affected traffic and are working with the parties involved to address with extreme urgency. Will provide a further update within next 30 minutes.
Posted Jul 12, 2024 - 11:25 BST
Investigating
We're currently investigating reports of degraded audio on inbound and outbound calling, and have escalated to the relevant carriers involved. We will provide a further update within the next hour.
Posted Jul 12, 2024 - 11:05 BST
This incident affected: (Legacy) CallSwitch - Core Network.